What browsers do you support?

Obsidian Portal officially supports the following browsers:

  • Google Chrome - version 29, 30, 31 (and above)
  • Firefox - version 23, 24, 25 (and above)
  • Safari - version 6.0, 7.0 (and above)
  • Internet Explorer - version 9 (not recommended), 10, 11 (and above)

We also support all modern mobile browsers (iOS Safari and the Android browser)