Saving a page reverts from https to http;

Jonathonathon's Avatar


17 Apr, 2016 09:23 PM

Having an access issue when editing the site. When I'm navigating the site using secure http (https) then save a page, it reverts me back to non-secure (http). Problem is the non-secure link dings a firewall or me. Can the save link (wiki, characters, adventure logs, settings, etc) revert back to a secure page if the edit page itself was accessed using secure http?

  1. 1 Posted by OPSupport on 19 Apr, 2016 09:37 PM

    OPSupport's Avatar

    I have captured the bug and will escalate to the development team. Thank you for your report.

    OP Support

  2. 2 Posted by Jonathonathon on 19 Apr, 2016 09:42 PM

    Jonathonathon's Avatar

    Glad to hear it. Thanks for the update. Unrealistic though it may be, any eta on a fix?

  3. 3 Posted by OPSupport on 19 Apr, 2016 09:44 PM

    OPSupport's Avatar

    I would speculate that the issue is that redirects have hard coding which is changing the protocol handler, and reverting you from HTTP to HTTPS.

    In order to guarantee a great browsing experience, ultimately a code-wide audit would need to take place. I know the development team has a significant backlog and higher priorities; I cannot say what the priority on this ticket will be until they triage it. Ensuring that users can update their campaign's while at work behind corporate firewalls is of course an important scenario.

    OP Support

  4. 4 Posted by Jonathonathon on 19 Apr, 2016 09:55 PM

    Jonathonathon's Avatar

    You mean reverting me from https to http right? Just want to ensure the bug is logged correctly.

    Admittedly a bit disappointed, sounds like a fix won't go out any time soon. Thanks for the answer regardless.

  5. 5 Posted by OPSupport on 19 Apr, 2016 10:00 PM

    OPSupport's Avatar

    The team is here to help, and will definitely triage your issue, and determine the impact/risk of the change, etc.

  6. Support Staff 6 Posted by OPSupport on 22 Apr, 2016 07:22 AM

    OPSupport's Avatar

    The development team has looked into the issue and will be making the appropriate change shortly.

  7. 7 Posted by Jonathonathon on 22 Apr, 2016 01:17 PM

    Jonathonathon's Avatar

    Hey that's great news, thanks for the update. Just as an aside, I also noticed the My Profile link from the top nav drop down also has similar behavior. Just noticed it the other day, sorry for not reporting it sooner.

  8. Support Staff 8 Posted by OPSupport on 26 Apr, 2016 12:33 AM

    OPSupport's Avatar

    The team investigated today and is working to understand if this is an application/programming issue or infrastructure configuration issue. No resolution has been posted at this time. Getting this resolved is absolutely a priority to the team.

  9. 9 Posted by Jonathonathon on 26 Apr, 2016 01:26 PM

    Jonathonathon's Avatar

    So we went from "implementing a fix" to "we're still investigating"? Guys...

    Same issue also happens on logout, for what it's worth.

  10. Support Staff 10 Posted by OPSupport on 26 Apr, 2016 02:13 PM

    OPSupport's Avatar

    The team believes it is an issue with a load balancer, and they are working on it at this hour.

  11. 11 Posted by weasel0 on 28 Apr, 2016 05:33 PM

    weasel0's Avatar

    Just saved color settings in my ShadowHack campaign and it gave the warning that it was converting to an HTTP and then did so when I continued. All the links I see are HTTPS but that is an issue.

  12. 12 Posted by weasel0 on 28 Apr, 2016 05:46 PM

    weasel0's Avatar

    Any save in the settings redirects to a non-secure HTTP://

  13. Support Staff 13 Posted by OPSupport on 28 Apr, 2016 07:54 PM

    OPSupport's Avatar

    Yes we have reproduced that behavior on our side.

    OP Support

Discussions are closed to public comments.
If you need help with Obsidian Portal please start a new discussion.

Keyboard shortcuts


? Show this help
ESC Blurs the current field

Comment Form

r Focus the comment reply box
^ + ↩ Submit the comment

You can use Command ⌘ instead of Control ^ on Mac